CVE-2009-10003
capnsquarepants wordcraft tag.php cross site scripting
- State
- Published
- Severity
- 3.5 Low
- Published
- Jan 29, 2023
- Updated
- Aug 7, 2024
- Reserved
- Jan 28, 2023
Description
A vulnerability was found in capnsquarepants wordcraft up to 0.6. It has been classified as problematic. Affected is an unknown function of the file tag.php. The manipulation of the argument tag leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 0.7 is able to address this issue. The patch is identified as be23028633e8105de92f387036871c03f34d3124. It is recommended to upgrade the affected component. VDB-219714 is the identifier assigned to this vulnerability.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 3.5 Low | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N | VulDB |
| 3.0 | 3.5 Low | CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N | VulDB |
| 2.0 | 4.0 Medium | AV:N/AC:L/Au:S/C:N/I:P/A:N | VulDB |
Weaknesses
- CWE-79 Cross Site Scripting
Affected Products
| Product | Versions |
|---|---|
wordcraftcapnsquarepants |
|
References
- https://vuldb.com/?id.219714vdb-entrytechnical-description
- https://vuldb.com/?ctiid.219714signaturepermissions-required
- https://github.com/capnsquarepants/wordcraft/commit/be23028633e8105de92f387036871c03f34d3124patch
- https://github.com/capnsquarepants/wordcraft/releases/tag/wordcraft-0.7patch
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.