CVE-2012-10009
404like Plugin 404Like.php checkPage sql injection
- State
- Published
- Severity
- 7.3 High
- Published
- Mar 20, 2023
- Updated
- Aug 6, 2024
- Reserved
- Mar 19, 2023
Description
A vulnerability was found in 404like Plugin up to 1.0.2 on WordPress. It has been classified as critical. Affected is the function checkPage of the file 404Like.php. The manipulation of the argument searchWord leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 1.0.2 is able to address this issue. The name of the patch is 2c4b589d27554910ab1fd104ddbec9331b540f7f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223404.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.3 High | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L | VulDB |
| 3.0 | 7.3 High | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L | VulDB |
| 2.0 | 7.5 High | AV:N/AC:L/Au:N/C:P/I:P/A:P | VulDB |
Weaknesses
- CWE-89 SQL Injection
Affected Products
| Product | Versions |
|---|---|
404like Pluginn/a |
|
References
- https://vuldb.com/?id.223404vdb-entrytechnical-description
- https://vuldb.com/?ctiid.223404signaturepermissions-required
- https://github.com/wp-plugins/404like/commit/2c4b589d27554910ab1fd104ddbec9331b540f7fpatch
- https://github.com/wp-plugins/404like/releases/tag/1.0.2patch
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.