CVE-2012-10015

BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery

State
Published
Severity
4.3 Medium
Published
May 30, 2023
Updated
Aug 6, 2024
Reserved
May 29, 2023

Read the record on cve.org

Description

A vulnerability was found in BestWebSoft Twitter Plugin up to 2.14 on WordPress. It has been classified as problematic. Affected is the function twttr_settings_page of the file twitter.php of the component Settings Page. The manipulation leads to cross-site request forgery. It is possible to launch the attack remotely. Upgrading to version 2.15 is able to address this issue. The patch is identified as a6d4659cbb2cbf18ccb0fb43549d5113d74e0146. It is recommended to upgrade the affected component. VDB-230154 is the identifier assigned to this vulnerability.

Scores

CVSSScoreVectorSource
3.14.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:NVulDB
3.04.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:NVulDB
2.05.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:NVulDB

Weaknesses

Affected Products

ProductVersions
Twitter PluginBestWebSoft
  • 2.0Affected
  • 2.1Affected
  • 2.2Affected
  • 2.3Affected
  • 2.4Affected
  • 2.5Affected
  • 2.6Affected
  • 2.7Affected
  • 2.8Affected
  • 2.9Affected
  • 2.10Affected
  • 2.11Affected
  • 2.12Affected
  • 2.13Affected
  • 2.14Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.