CVE-2014-125051

himiklab yii2-jqgrid-widget JqGridAction.php addSearchOptionsRecursively sql injection

State
Published
Severity
5.5 Medium
Published
Jan 6, 2023
Updated
Aug 6, 2024
Reserved
Jan 6, 2023

Read the record on cve.org

Description

A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.

Scores

CVSSScoreVectorSource
3.15.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LVulDB
3.05.5 MediumCVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LVulDB
2.05.2 MediumAV:A/AC:L/Au:S/C:P/I:P/A:PVulDB

Weaknesses

Affected Products

ProductVersions
yii2-jqgrid-widgethimiklab
  • 1.0.0Affected
  • 1.0.1Affected
  • 1.0.2Affected
  • 1.0.3Affected
  • 1.0.4Affected
  • 1.0.5Affected
  • 1.0.6Affected
  • 1.0.7Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.