CVE-2015-10009

nterchange code_caller_controller.php getContent code injection

State
Published
Severity
5.5 Medium
Published
Jan 2, 2023
Updated
Aug 6, 2024
Reserved
Jan 2, 2023

Read the record on cve.org

Description

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

Scores

CVSSScoreVectorSource
3.15.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LVulDB
3.05.5 MediumCVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LVulDB
2.05.2 MediumAV:A/AC:L/Au:S/C:P/I:P/A:PVulDB

Weaknesses

Affected Products

ProductVersions
nterchangen/a
  • 4.0Affected
  • 4.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.