CVE-2015-10094

Fastly Plugin api.php post cross site scripting

State
Published
Severity
2.4 Low
Published
Mar 6, 2023
Updated
Aug 6, 2024
Reserved
Mar 4, 2023

Read the record on cve.org

Description

A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.

Scores

CVSSScoreVectorSource
3.12.4 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:NVulDB
3.02.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:NVulDB
2.03.3 LowAV:N/AC:L/Au:M/C:N/I:P/A:NVulDB

Weaknesses

Affected Products

ProductVersions
Fastly Pluginn/a
  • 0.1Affected
  • 0.2Affected
  • 0.3Affected
  • 0.4Affected
  • 0.5Affected
  • 0.6Affected
  • 0.7Affected
  • 0.8Affected
  • 0.9Affected
  • 0.10Affected
  • 0.11Affected
  • 0.12Affected
  • 0.13Affected
  • 0.14Affected
  • 0.15Affected
  • 0.16Affected
  • 0.17Affected
  • 0.18Affected
  • 0.19Affected
  • 0.20Affected
  • 0.21Affected
  • 0.22Affected
  • 0.23Affected
  • 0.24Affected
  • 0.25Affected
  • and 72 more versions

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.