CVE-2018-1000073
- State
- Published
- Severity
- Not scored
- Published
- Mar 13, 2018
- Updated
- Aug 5, 2024
- Reserved
- Feb 21, 2018
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.
Scores
The record has no CVSS score.
Weaknesses
The record names no weakness.
Affected Products
| Product | Versions |
|---|---|
n/an/a |
|
References
- DSA-4219vendor-advisory
- USN-3621-1vendor-advisory
- RHSA-2018:3729vendor-advisory
- RHSA-2018:3730vendor-advisory
- RHSA-2018:3731vendor-advisory
- https://github.com/rubygems/rubygems/commit/1b931fc03b819b9a0214be3eaca844ef534175e2
- [debian-lts-announce] 20180827 [SECURITY] [DLA 1480-1] ruby2.1 security updatemailing-list
- DSA-4259vendor-advisory
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- openSUSE-SU-2019:1771vendor-advisory
- RHSA-2019:2028vendor-advisory
- RHSA-2020:0542vendor-advisory
- RHSA-2020:0591vendor-advisory
- RHSA-2020:0663vendor-advisory
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.