CVE-2018-16839
- State
- Published
- Severity
- 4.3 Medium
- Published
- Oct 31, 2018
- Updated
- Apr 15, 2026
- Reserved
- Sep 11, 2018
Description
Curl versions 7.33.0 through 7.61.1 are vulnerable to a buffer overrun in the SASL authentication code that may lead to denial of service.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.0 | 4.3 Medium | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L | redhat |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
curl:The Curl Project |
|
References
- GLSA-201903-03vendor-advisory
- DSA-4331vendor-advisory
- [debian-lts-announce] 20181106 [SECURITY] [DLA 1568-1] curl security updatemailing-list
- https://curl.haxx.se/docs/CVE-2018-16839.html
- https://github.com/curl/curl/commit/f3a24d7916b9173c69a3e0ee790102993833d6c5
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16839
- 1042012vdb-entry
- USN-3805-1vendor-advisory
- [infra-devnull] 20190404 [GitHub] [incubator-openwhisk-runtime-ballerina] falkzoll commented on issue #15: Update to new base image jdk8u202-b08_openj9-0.12.1.mailing-list
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.