CVE-2018-25031

State
Published
Severity
4.3 Medium
Published
Mar 11, 2022
Updated
Aug 5, 2024
Reserved
Mar 11, 2022

Read the record on cve.org

Description

Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.

Scores

CVSSScoreVectorSource
3.14.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:NCISA-ADP

Weaknesses

  • CWE-922 Insecure Storage of Sensitive Information
  • CWE-918 Server-Side Request Forgery (SSRF)
  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
n/an/a
  • n/aAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.