CVE-2018-25070

polterguy Phosphorus Five CSV Import NonQuery.cs csv.Read sql injection

State
Published
Severity
5.5 Medium
Published
Jan 7, 2023
Updated
Apr 9, 2025
Reserved
Jan 7, 2023

Read the record on cve.org

Description

A vulnerability has been found in polterguy Phosphorus Five up to 8.2 and classified as critical. This vulnerability affects the function csv.Read of the file plugins/extras/p5.mysql/NonQuery.cs of the component CSV Import. The manipulation leads to sql injection. Upgrading to version 8.3 is able to address this issue. The patch is identified as c179a3d0703db55cfe0cb939b89593f2e7a87246. It is recommended to upgrade the affected component. VDB-217606 is the identifier assigned to this vulnerability.

Scores

CVSSScoreVectorSource
3.15.5 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LVulDB
3.05.5 MediumCVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LVulDB
2.05.2 MediumAV:A/AC:L/Au:S/C:P/I:P/A:PVulDB

Weaknesses

Affected Products

ProductVersions
Phosphorus Fivepolterguy
  • 8.0Affected
  • 8.1Affected
  • 8.2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.