CVE-2019-16780

Stored cross-site scripting (XSS) in WordPress block editor

State
Published
Severity
5.8 Medium
Published
Dec 26, 2019
Updated
Aug 5, 2024
Reserved
Sep 24, 2019

Read the record on cve.org

Description

WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.

Scores

CVSSScoreVectorSource
3.15.8 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:NGitHub_M

Weaknesses

  • CWE-79 Cross-site Scripting (XSS)

Affected Products

ProductVersions
WordPressWordPress
  • < 5.3.1 to before 5.3.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.