CVE-2019-19348

State
Published
Severity
7.0 High
Published
Apr 2, 2020
Updated
Aug 5, 2024
Reserved
Nov 27, 2019

Read the record on cve.org

Description

An insecure modification vulnerability in the /etc/passwd file was found in the container openshift/apb-base, affecting versions before the following 4.3.5, 4.2.21, 4.1.37, and 3.11.188-4. An attacker with access to the container could use this flaw to modify /etc/passwd and escalate their privileges.

Scores

CVSSScoreVectorSource
3.17.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:Hredhat

Weaknesses

Affected Products

ProductVersions
openshift/apb-baseOpenshift Enterprise
  • Fixed in 4.3.5-202003020549Affected
  • Fixed in 4.2.21-202002240343Affected
  • Fixed in 4.1.37-202003021622Affected
  • Fixed in 3.11.188-4Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.