CVE-2019-25078
pacparser pacparser.c pacparser_find_proxy buffer overflow
- State
- Published
- Severity
- 5.3 Medium
- Published
- Dec 13, 2022
- Updated
- Aug 5, 2024
- Reserved
- Dec 13, 2022
Description
A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 5.3 Medium | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L | VulDB |
Weaknesses
- CWE-119 Memory Corruption -> CWE-120 Buffer Overflow
Affected Products
| Product | Versions |
|---|---|
pacparserunspecified |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.