CVE-2019-3829

State
Published
Severity
5.3 Medium
Published
Mar 27, 2019
Updated
Aug 4, 2024
Reserved
Jan 3, 2019

Read the record on cve.org

Description

A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.

Scores

CVSSScoreVectorSource
3.05.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Lredhat

Weaknesses

Affected Products

ProductVersions
gnutlsgnutls
  • fixed in 3.6.7Affected
  • affected from 3.5.8Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.