CVE-2020-11001
Possible XSS attack in Wagtail
- State
- Published
- Severity
- 5.8 Medium
- Published
- Apr 14, 2020
- Updated
- Nov 19, 2024
- Reserved
- Mar 30, 2020
Description
In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 5.8 Medium | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N | GitHub_M |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
wagtailwagtail |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.