CVE-2020-11030

Cross-site scripting (XSS) in Search block in WordPress

State
Published
Severity
6.4 Medium
Published
Apr 30, 2020
Updated
Aug 4, 2024
Reserved
Mar 30, 2020

Read the record on cve.org

Description

In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Scores

CVSSScoreVectorSource
3.16.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NGitHub_M

Weaknesses

Affected Products

ProductVersions
WordPressWordPress
  • >= 5.4.0, < 5.4.1Affected
  • >= 5.3.0, < 5.3.3Affected
  • >= 5.2.0, < 5.2.6Affected
  • >= 5.1.0, < 5.1.5Affected
  • >= 5.0.0, < 5.0.9Affected
  • >= 4.9.0, < 4.9.14Affected
  • >= 4.8.0, < 4.8.13Affected
  • >= 4.7.0, < 4.7.17Affected
  • >= 4.6.0, < 4.6.18Affected
  • >= 4.5.0, < 4.5.21Affected
  • >= 4.4.0, < 4.4.22Affected
  • >= 4.3.0, < 4.3.23Affected
  • >= 4.2.0, < 4.2.27Affected
  • >= 4.1.0, < 4.1.30Affected
  • >= 4.0.0, < 4.0.30Affected
  • >= 3.9.0, < 3.9.31Affected
  • >= 3.8.0, < 3.8.33Affected
  • >= 3.7.0, < 3.7.33Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.