CVE-2020-11052
Improper Restriction of Excessive Authentication Attempts in Sorcery
- State
- Published
- Severity
- 8.3 High
- Published
- May 7, 2020
- Updated
- Aug 4, 2024
- Reserved
- Mar 30, 2020
Description
In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 8.3 High | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L | GitHub_M |
Weaknesses
- CWE-307 Improper Restriction of Excessive Authentication Attempts
Affected Products
| Product | Versions |
|---|---|
SorcerySorcery |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.