CVE-2020-15107
x87 FPU operations in enclaves are vulnerable to ABI poisoning in openenclave
- State
- Published
- Severity
- 5.3 Medium
- Published
- Jul 15, 2020
- Updated
- Aug 4, 2024
- Reserved
- Jun 25, 2020
Description
In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 5.3 Medium | CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N | GitHub_M |
Weaknesses
The record names no weakness.
Affected Products
| Product | Versions |
|---|---|
openenclaveopenenclave |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.