CVE-2020-15138
Cross-Site Scripting in Prism
- State
- Published
- Severity
- 7.1 High
- Published
- Aug 7, 2020
- Updated
- Aug 4, 2024
- Reserved
- Jun 25, 2020
Description
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.1 High | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L | GitHub_M |
Weaknesses
- CWE-79 {"CWE-79":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}
Affected Products
| Product | Versions |
|---|---|
prismPrismJS |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.