CVE-2020-15150
Remote Code Execution in paginator(hex)
- State
- Published
- Severity
- 9.0 Critical
- Published
- Sep 1, 2020
- Updated
- Aug 4, 2024
- Reserved
- Jun 25, 2020
Description
There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 9.0 Critical | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H | GitHub_M |
Weaknesses
- CWE-94 {"CWE-94":"Improper Control of Generation of Code ('Code Injection')"}
Affected Products
| Product | Versions |
|---|---|
paginatorduffelhq |
|
References
- https://github.com/duffelhq/paginator/security/advisories/GHSA-w98m-2xqg-9cvj
- https://hex.pm/packages/paginator
- https://github.com/duffelhq/paginator/commit/bf45e92602e517c75aea0465efc35cd661d9ebf8
- https://github.com/duffelhq/paginator/blob/ccf0f37fa96347cc8c8a7e9eb2c64462cec4b2dc/README.md#security-considerations
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.