CVE-2020-4043
Phar unserialization vulnerability in phpMussel
- State
- Published
- Severity
- 7.7 High
- Published
- Jun 10, 2020
- Updated
- Aug 4, 2024
- Reserved
- Dec 30, 2019
Description
phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.7 High | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N | GitHub_M |
Weaknesses
- CWE-502 Deserialization of Untrusted Data
Affected Products
| Product | Versions |
|---|---|
phpMusselphpMussel |
|
References
- https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh
- https://github.com/phpMussel/phpMussel/issues/167
- https://github.com/phpMussel/phpMussel/pull/173
- https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4
- https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.