CVE-2020-4046

Authenticated XSS through embed block in WordPress

State
Published
Severity
5.4 Medium
Published
Jun 12, 2020
Updated
Aug 4, 2024
Reserved
Dec 30, 2019

Read the record on cve.org

Description

In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to script execution in the editor/wp-admin. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Scores

CVSSScoreVectorSource
3.15.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NGitHub_M

Weaknesses

  • CWE-80 Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)

Affected Products

ProductVersions
wordpress-developWordPress
  • >= 5.4.0, < 5.4.2Affected
  • >= 5.3.0, < 5.3.4Affected
  • >= 5.2.0, < 5.2.7Affected
  • >= 5.1.0, < 5.1.6Affected
  • >= 5.0.0, < 5.0.10Affected
  • >= 4.9.0, < 4.9.15Affected
  • >= 4.8.0, < 4.8.14Affected
  • >= 4.7.0, < 4.7.18Affected
  • >= 4.6.0, < 4.6.19Affected
  • >= 4.5.0, < 4.5.22Affected
  • >= 4.4.0, < 4.4.23Affected
  • >= 4.3.0, < 4.3.24Affected
  • >= 4.2.0, < 4.2.28Affected
  • >= 4.1.0, < 4.1.31Affected
  • >= 4.0.0, < 4.0.31Affected
  • >= 3.9.0, < 3.9.32Affected
  • >= 3.8.0, < 3.8.34Affected
  • >= 3.7.0, < 3.7.34Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.