CVE-2020-5216
Limited header injection when using dynamic overrides with user input in RubyGems secure_headers
- State
- Published
- Severity
- 4.4 Medium
- Published
- Jan 23, 2020
- Updated
- Aug 4, 2024
- Reserved
- Jan 2, 2020
Description
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 4.4 Medium | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N | GitHub_M |
Weaknesses
- CWE-113 Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Response Splitting')
Affected Products
| Product | Versions |
|---|---|
secure_headersTwitter |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.