CVE-2021-21365

Cross-Site Scripting in Content Rendering

State
Published
Severity
5.4 Medium
Published
Apr 27, 2021
Updated
Aug 3, 2024
Reserved
Dec 22, 2020

Read the record on cve.org

Description

Bootstrap Package is a theme for TYPO3. It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability. Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix. Update to version 7.1.2, 8.0.8, 9.1.4, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described. Updated version are available from the TYPO3 extension manager, Packagist and at https://extensions.typo3.org/extension/download/bootstrap_package/.

Scores

CVSSScoreVectorSource
3.15.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
bootstrap_packagebenjaminkott
  • >= 7.1.0, < 7.1.2Affected
  • >= 8.0.0, < 8.0.8Affected
  • >= 9.0.0, < 9.0.4Affected
  • >= 9.1.0, < 9.1.3Affected
  • >= 10.0.0, < 10.0.10Affected
  • >= 11.0.0, < 11.0.3Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.