CVE-2021-29447

WordPress Authenticated XXE attack when installation is running PHP 8

State
Published
Severity
7.1 High
Published
Apr 15, 2021
Updated
Aug 3, 2024
Reserved
Mar 30, 2021

Read the record on cve.org

Description

Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

Scores

CVSSScoreVectorSource
3.17.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:NGitHub_M

Weaknesses

  • CWE-611 {"CWE-611":"Improper Restriction of XML External Entity Reference"}

Affected Products

ProductVersions
wordpress-developWordPress
  • >= 5.6.0, < 5.7.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.