CVE-2021-40865

Unsafe Pre-Authentication Deserialization In Workers

State
Published
Severity
Not scored
Published
Oct 25, 2021
Updated
Aug 4, 2024
Reserved
Sep 12, 2021

Read the record on cve.org

Description

An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4

Scores

The record has no CVSS score.

Weaknesses

  • CWE-502 Deserialization of Untrusted Data

Affected Products

ProductVersions
Apache StormApache Software Foundation
  • v1.0.0 to before Apache Storm *Affected
  • Apache Storm to before v1.2.4Affectedfrom v2.1.1Not affectedfrom v2.2.1Not affectedfrom v2.3.0Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.