CVE-2021-43850

Denial of Service in discourse

State
Published
Severity
6.8 Medium
Published
Jan 4, 2022
Updated
Apr 22, 2025
Reserved
Nov 16, 2021

Read the record on cve.org

Description

Discourse is an open source platform for community discussion. In affected versions admins users can trigger a Denial of Service attack via the `/message-bus/_diagnostics` path. The impact of this vulnerability is greater on multisite Discourse instances (where multiple forums are served from a single application server) where any admin user on any of the forums are able to visit the `/message-bus/_diagnostics` path. The problem has been patched. Please upgrade to 2.8.0.beta10 or 2.7.12. No workarounds for this issue exist.

Scores

CVSSScoreVectorSource
3.16.8 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:HGitHub_M

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
discoursediscourse
  • < 2.7.12Affected
  • >= 2.8.0.beta, < 2.8.0.beta10Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.