CVE-2021-4428

what3words Autosuggest Plugin Setting class-w3w-autosuggest-public.php enqueue_scripts information disclosure

State
Published
Severity
2.7 Low
Published
Jul 18, 2023
Updated
Aug 3, 2024
Reserved
Jul 16, 2023

Read the record on cve.org

Description

A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.

Scores

CVSSScoreVectorSource
3.12.7 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:NVulDB
3.02.7 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:NVulDB
2.03.3 LowAV:N/AC:L/Au:M/C:P/I:N/A:NVulDB

Weaknesses

Affected Products

ProductVersions
Autosuggest Pluginwhat3words
  • 4.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.