CVE-2022-31121

Improper Input Validation in fabric hyperledger

State
Published
Severity
7.5 High
Published
Jul 7, 2022
Updated
Apr 23, 2025
Reserved
May 18, 2022

Read the record on cve.org

Description

Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HGitHub_M

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
fabrichyperledger
  • < 2.2.7Affected
  • >= 2.3.0, < 2.4.5Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.