CVE-2022-31157
Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library
- State
- Published
- Severity
- 7.5 High
- Published
- Jul 15, 2022
- Updated
- Apr 23, 2025
- Reserved
- May 18, 2022
Description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.5 High | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | GitHub_M |
Weaknesses
- CWE-327 Use of a Broken or Risky Cryptographic Algorithm
Affected Products
| Product | Versions |
|---|---|
lti-1-3-php-librarypackbackbooks |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.