CVE-2022-31800

Insufficient Verification of Data Vulnerability in PHOENIX CONTACT classic line industrial controllers

State
Published
Severity
9.8 Critical
Published
Jun 21, 2022
Updated
Jun 2, 2026
Reserved
May 30, 2022

Read the record on cve.org

Description

An unauthenticated, remote attacker could upload malicious logic to devices based on ProConOS/ProConOS eCLR in order to gain full control over the device.

Scores

CVSSScoreVectorSource
3.19.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HCERTVDE

Weaknesses

  • CWE-345 Insufficient Verification of Data Authenticity

Affected Products

ProductVersions
ILC 1x0PHOENIX CONTACT
  • All VersionsAffected
ILC 1x1PHOENIX CONTACT
  • All VersionsAffected
ILC 1x1 GSM/GPRSPHOENIX CONTACT
  • All VersionsAffected
ILC 3xxPHOENIX CONTACT
  • All VersionsAffected
AXC 1050PHOENIX CONTACT
  • All VersionsAffected
AXC 1050 XCPHOENIX CONTACT
  • All VersionsAffected
AXC 3050PHOENIX CONTACT
  • All VersionsAffected
RFC 480S PN 4TXPHOENIX CONTACT
  • All VersionsAffected
RFC 470 PN 3TXPHOENIX CONTACT
  • All VersionsAffected
RFC 470S PN 3TXPHOENIX CONTACT
  • All VersionsAffected
RFC 460R PN 3TXPHOENIX CONTACT
  • All VersionsAffected
RFC 460R PN 3TX-SPHOENIX CONTACT
  • All VersionsAffected
RFC 430 ETH-IBPHOENIX CONTACT
  • All VersionsAffected
RFC 450 ETH-IBPHOENIX CONTACT
  • All VersionsAffected
PC WORX SRTPHOENIX CONTACT
  • All VersionsAffected
PC WORX RT BASICPHOENIX CONTACT
  • All VersionsAffected
FC 350 PCI ETHPHOENIX CONTACT
  • All VersionsAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.