CVE-2022-34169

Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets

State
Published
Severity
7.5 High
Published
Jul 19, 2022
Updated
May 27, 2026
Reserved
Jun 21, 2022

Read the record on cve.org

Description

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NCISA-ADP

Weaknesses

  • CWE-681 Incorrect Conversion between Numeric Types

Affected Products

ProductVersions
Apache Xalan-JApache Software Foundation
  • Xalan-J through 2.7.2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.