CVE-2022-36023

Remote denial of service in Hyperledger Fabric Gateway

State
Published
Severity
7.0 High
Published
Aug 18, 2022
Updated
Apr 23, 2025
Reserved
Jul 15, 2022

Read the record on cve.org

Description

Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.

Scores

CVSSScoreVectorSource
3.17.0 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:HGitHub_M

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
fabrichyperledger
  • < 2.4.6Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.