CVE-2022-42009

Apache Ambari: A malicious authenticated user can remotely execute arbitrary code in the context of the application.

State
Published
Severity
8.0 High
Published
Jul 12, 2023
Updated
Oct 4, 2024
Reserved
Oct 2, 2022

Read the record on cve.org

Description

SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

Scores

CVSSScoreVectorSource
3.18.0 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:Hapache

Weaknesses

  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement ('Expression Language Injection')

Affected Products

ProductVersions
Apache AmbariApache Software Foundation
  • 2.7.0 through 2.7.6Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.