CVE-2023-0872
ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
- State
- Published
- Severity
- 8.2 High
- Published
- Aug 14, 2023
- Updated
- Oct 3, 2024
- Reserved
- Feb 16, 2023
Description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks Erik Wynter for reporting this issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 8.2 High | CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L | OpenNMS |
Weaknesses
- CWE-269 Improper Privilege Management
Affected Products
| Product | Versions |
|---|---|
HorizonThe OpenNMS Group |
|
MeridianThe OpenNMS Group |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.