CVE-2023-1277
kylin-system-updater Update InstallSnap command injection
- State
- Published
- Severity
- 7.8 High
- Published
- Mar 8, 2023
- Updated
- Feb 28, 2025
- Reserved
- Mar 8, 2023
Description
A vulnerability, which was classified as critical, was found in kylin-system-updater up to 1.4.20kord on Ubuntu Kylin. Affected is the function InstallSnap of the component Update Handler. The manipulation leads to command injection. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-222600.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.8 High | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | VulDB |
| 3.0 | 7.8 High | CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | VulDB |
| 2.0 | 6.8 Medium | AV:L/AC:L/Au:S/C:C/I:C/A:C | VulDB |
Weaknesses
- CWE-77 Command Injection
Affected Products
| Product | Versions |
|---|---|
kylin-system-updatern/a |
|
References
- https://vuldb.com/?id.222600vdb-entrytechnical-description
- https://vuldb.com/?ctiid.222600signaturepermissions-required
- https://github.com/cn-lwj/vuldb/blob/master/kylin-system-updater_vuln.mdbroken-linkexploitpatch
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.