CVE-2023-25565
GSS-NTLMSSP vulnerable to incorrect free when decoding target information
- State
- Published
- Severity
- 7.5 High
- Published
- Feb 14, 2023
- Updated
- Mar 10, 2025
- Reserved
- Feb 7, 2023
Description
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.5 High | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub_M |
Weaknesses
- CWE-590 Free of Memory not on the Heap
Affected Products
| Product | Versions |
|---|---|
gss-ntlmsspgssapi |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.