CVE-2023-3204

Materialis <= 1.1.24 - Missing Authorization to Limited Arbitrary Options Update

State
Published
Severity
6.5 Medium
Published
Jun 20, 2024
Updated
Apr 8, 2026
Reserved
Jun 12, 2023

Read the record on cve.org

Description

The Materialis theme for WordPress is vulnerable to limited arbitrary options updates in versions up to, and including, 1.1.24. This is due to missing authorization checks on the companion_disable_popup() function called via an AJAX action. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to modify any option on the site to a numerical value.

Scores

CVSSScoreVectorSource
3.16.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NWordfence

Weaknesses

Affected Products

ProductVersions
Materialisextendthemes
  • 1.1.24 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.