CVE-2023-34110
Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user error
- State
- Published
- Severity
- 2.7 Low
- Published
- Jun 22, 2023
- Updated
- Dec 6, 2024
- Reserved
- May 25, 2023
Description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 2.7 Low | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N | GitHub_M |
Weaknesses
- CWE-209 Generation of Error Message Containing Sensitive Information
Affected Products
| Product | Versions |
|---|---|
Flask-AppBuilderdpgaspar |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.