CVE-2023-43826
Apache Guacamole: Integer overflow in handling of VNC image buffers
- State
- Published
- Severity
- 7.5 High
- Published
- Dec 19, 2023
- Updated
- Feb 25, 2026
- Reserved
- Sep 25, 2023
Description
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process.
Users are recommended to upgrade to version 1.5.4, which fixes this issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.5 High | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H | apache |
| 3.1 | 7.0 High | CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H | apache |
| 3.1 | 0.0 None | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:N | apache |
Weaknesses
- CWE-190 Integer Overflow or Wraparound
Affected Products
| Product | Versions |
|---|---|
Apache GuacamoleApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.