CVE-2023-4504

OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow

State
Published
Severity
7.0 High
Published
Sep 21, 2023
Updated
Nov 4, 2025
Reserved
Aug 23, 2023

Read the record on cve.org

Description

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Scores

CVSSScoreVectorSource
3.17.0 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HCISA-ADP

Weaknesses

Affected Products

ProductVersions
CUPSOpenPrinting
  • before 2.4.6Affected
libppdOpenPrinting
  • before d09348bAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.