CVE-2023-46724

SQUID-2023:4 Denial of Service in SSL Certificate validation

State
Published
Severity
8.6 High
Published
Nov 1, 2023
Updated
Feb 13, 2025
Reserved
Oct 25, 2023

Read the record on cve.org

Description

Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.

Scores

CVSSScoreVectorSource
3.18.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:HGitHub_M

Weaknesses

  • CWE-125 Out-of-bounds Read
  • CWE-129 Improper Validation of Array Index
  • CWE-786 Access of Memory Location Before Start of Buffer
  • CWE-823 Use of Out-of-range Pointer Offset
  • CWE-1285 Improper Validation of Specified Index, Position, or Offset in Input

Affected Products

ProductVersions
squidsquid-cache
  • >= 3.3.0.1, < 6.4Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.