CVE-2023-47121
Discourse SSRF vulnerability in Embedding
- State
- Published
- Severity
- 3.4 Low
- Published
- Nov 10, 2023
- Updated
- Feb 27, 2025
- Reserved
- Oct 30, 2023
Description
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 3.4 Low | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N | GitHub_M |
Weaknesses
- CWE-918 Server-Side Request Forgery (SSRF)
Affected Products
| Product | Versions |
|---|---|
discoursediscourse |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.