CVE-2023-47248

PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file

State
Published
Severity
Not scored
Published
Nov 9, 2023
Updated
Feb 13, 2025
Reserved
Nov 4, 2023

Read the record on cve.org

Description

Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).

This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.

It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.

If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.

Scores

The record has no CVSS score.

Weaknesses

  • CWE-502 Deserialization of Untrusted Data

Affected Products

ProductVersions
PyArrowApache Software Foundation
  • 0.14.0 through 14.0.0Affected
PyArrowApache Software Foundation
  • 0.14.0 through 14.0.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.