CVE-2023-49299

Apache DolphinScheduler: Arbitrary js execute as root for authenticated users

State
Published
Severity
8.8 High
Published
Dec 30, 2023
Updated
Feb 13, 2025
Reserved
Nov 26, 2023

Read the record on cve.org

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9.

Users are recommended to upgrade to version 3.1.9, which fixes the issue.

Scores

CVSSScoreVectorSource
3.18.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HCISA-ADP

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
Apache DolphinSchedulerApache Software Foundation
  • before 3.1.9Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.