CVE-2023-6804

Improper Privilege Management allows for arbitrary workflows to be run

State
Published
Severity
6.5 Medium
Published
Dec 21, 2023
Updated
Nov 27, 2024
Reserved
Dec 13, 2023

Read the record on cve.org

Description

Improper privilege management allowed arbitrary workflows to be committed and run using an improperly scoped PAT. To exploit this, a workflow must have already existed in the target repo. This vulnerability affected all versions of GitHub Enterprise Server since 3.8 and was fixed in version 3.8.12, 3.9.7, 3.10.4, and 3.11.1.

Scores

CVSSScoreVectorSource
3.16.5 MediumCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:LGitHub_P

Weaknesses

  • CWE-269 Improper Privilege Management

Affected Products

ProductVersions
Enterprise ServerGitHub
  • 3.8.0 through 3.8.11Affectedfrom 3.8.12Not affected
  • 3.9.0 through 3.9.6Affectedfrom 3.9.7Not affected
  • 3.10.0 through 3.10.3Affectedfrom 3.10.4Not affected
  • 3.11 through 3.11.0Affectedfrom 3.11.1Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.