CVE-2024-10326

RomethemeKit For Elementor <= 1.5.3 - Missing Authorization in save_options and reset_widgets

State
Published
Severity
4.3 Medium
Published
Mar 8, 2025
Updated
Apr 8, 2026
Reserved
Oct 23, 2024

Read the record on cve.org

Description

The RomethemeKit For Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_options and reset_widgets functions in all versions up to, and including, 1.5.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify plugin settings or reset plugin widgets to their default state (all enabled). NOTE: This vulnerability was partially fixed in version 1.5.3.

Scores

CVSSScoreVectorSource
3.14.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:NWordfence

Weaknesses

Affected Products

ProductVersions
RTMKitrometheme
  • 1.5.3 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.