CVE-2024-10720

Stored Cross-site Scripting (XSS) in phpipam/phpipam

State
Published
Severity
8.2 High
Published
Mar 20, 2025
Updated
Mar 20, 2025
Reserved
Nov 1, 2024

Read the record on cve.org

Description

A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability occurs in the 'Device Management' section under 'Administration' where an attacker can inject malicious scripts into the 'Name' and 'Description' fields when adding a new device type. This can lead to data theft, account compromise, distribution of malware, website defacement, and phishing attacks. The issue is fixed in version 1.7.0.

Scores

CVSSScoreVectorSource
3.08.2 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:H@huntr_ai

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
phpipam/phpipamphpipam
  • before 1.7.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.