CVE-2024-10722

Stored Cross-site Scripting (XSS) in phpipam/phpipam

State
Published
Severity
3.5 Low
Published
Mar 20, 2025
Updated
Mar 20, 2025
Reserved
Nov 1, 2024

Read the record on cve.org

Description

A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability allows attackers to inject malicious scripts into the 'Description' field of custom fields in the 'IP RELATED MANAGEMENT' section. This can lead to data theft, account compromise, distribution of malware, website defacement, content manipulation, and phishing attacks. The issue is fixed in version 1.7.0.

Scores

CVSSScoreVectorSource
3.03.5 LowCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N@huntr_ai

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
phpipam/phpipamphpipam
  • before 1.7.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.