CVE-2024-10723

Stored XSS in phpipam/phpipam

State
Published
Severity
3.5 Low
Published
Mar 20, 2025
Updated
Mar 20, 2025
Reserved
Nov 1, 2024

Read the record on cve.org

Description

A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the destination address field of the NAT tool, which can be executed when a user interacts with the field. The impact of this vulnerability includes the potential theft of user cookies, unauthorized access to user accounts, and redirection to malicious websites. The issue has been fixed in version 1.7.0.

Scores

CVSSScoreVectorSource
3.03.5 LowCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N@huntr_ai

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
phpipam/phpipamphpipam
  • before 1.7.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.